Capture also records title bar on Windows 8.1

Jul 25, 2014 at 1:15 PM
Any ideas?

For some reason it doesn't just capture the zone within the ScreenToGrab window on Windows 8.1

It also captures the title bar, almost as if it is recording from the top left most point of the window.

If you need an example I can provide one.

Really annoying as I love the simplicity, would have a look at try to fix myself but short on time at the moment

*Note, looks like this issue isn't just related to ScreenToGit, seems to affect all similar programs like LiceCap
Jul 25, 2014 at 1:23 PM
Just tried using compatibility more and run as adminsitrator, no luck.

Here's a screenshot!
Jul 25, 2014 at 2:52 PM
My guess is: DPI settings. (It could be something else)

I faced this problem back when I was developping the Modern version, It was related with screen DPI (with W8.1). They changed the way DPI settings are controlled with the new OS. I thought it was resolved.
It also captures the title bar, almost as if it is recording from the top left most point of the window.
Yes, that's how it's done. I do some calculations to get the offset of the transparent area, to record in the right position.

I did some testing with DPI at 125% and 150%, it works well with the release 0.9 and 1.1. I just found another bug related with the DPI: The treeView of frames is not being displayed correctly. (that box in the left side)

Recordind at 125%

Can you give more details?

• Screen resolution?
• Are you using a secondary screen?
• Screen DPI?
• ScreenToGif version?
• Tried to use the legacy version?
Jul 25, 2014 at 3:21 PM
You managed to get there just before me. Came across an old issue with high DPI, however with Windows 8 that wasn't the specific issue but led me to it.
By default Windows 8 scales the DPI for the primary monitor, to make "icons" appear larger on screens. This seems to do some funky twitching with the DPI.

By setting the Display scaling to "small icons" in the control panel (Display -> Change the size of all items) page, you set text/icons to smaller (default larger)

This seems to correct the issue.

Thanks for the guidance.

Probably worth mentioning in a readme somewhere :D
Jul 26, 2014 at 10:30 PM
Alright, let me understand, in my testing, using 125% and 150%, resulted a correct recording (Slider set to the middle and in the other test, to the right).

But for you, using +100% ends up glitching the program? (Slider more to the right)

I was using the version 1.1 and the modern theme.
Jul 26, 2014 at 11:25 PM
Sorry, missed you reply when I was commenting it was working.

My Screen resolution was 1600x900 and the Screen scaling was set to maximum. (larger)
I'm using the latest build that is on the download link at the moment.

Setting the scaling down to 0 (left most setting) fixes the issue and reverts to the native resolution. (smaller)

Tried both the modern interface and the legacy one and it was the same effect.

Hoe this helps narrow it down. When I do get a sec I'll grab the source and see if I can find the root cause or the values reported in code.
Jul 27, 2014 at 6:13 PM
Well, that's strange, tweaking those settings do nothing harmful to the program in my tests. I'm missing something...

If you need help, I'll show you where to look and the correct values to expect.

Aug 29, 2014 at 1:39 AM
I just tried the above solution, and it did work.

Resolution is 1920 x 1080
The slider inside Display settings was right at the middle

Moving it all the way to the left fixed the issue for me